Requirements for the pH7 "Dating Community Social" software

Server:

Minimum:

  • Operating System - Linux/Unix (Red Hat, CentOS, Debian, FreeBSD, Mandrake, Mac OS, etc.), Windows.
  • Web Server - Apache with mod_php enabled, PHP in CGI, FastCGI mode, or with nginx (lighttpd, LiteSpeed and IIS should also work but you have to change some piece of code to make it working).
  • URL rewriting extension module - Apache, nginx, lighttpd, LiteSpeed, IIS (for Web.config, you have a good tutorial here).
  • Minimum Web Space - 2.0 GB
  • Specific Requirement - Server has to be connected to Internet
  • Video Module Requirement (only if enabled) - FFmpeg

Recommended:

  • JRE (Java Runtime Environment) - 1.6 or higher (used for compressing static files. The option is disabled by default and uses our homemade compressor instead. However, if you have Java installed on your server, it would be nicer to enable that option).
  • mod_security/mod_security2 disabled - pH7CMS may not work correctly if enabled so we advise to disable it for your domain (just ask your Web host or do it through cPanel).

PHP:

Minimum:

  • Version - 5.6 or higher
  • PDO extension
  • exec() PHP (system program execution) must be allowed
  • GD complied with your PHP Build
  • PHP CURL extension
  • Zip compression PHP module
  • Zlib compression PHP module
  • mbstring PHP module
  • exif PHP extension
  • dom PHP extension
  • xml PHP extension
  • Send Mail PHP activated
  • memory_limit - 128M or higher
  • max_input_time - -1 (Unlimited)
  • post_max_size - 100M or higher
  • upload_max_filesize - 100M or higher
  • file_uploads - On
  • allow_url_fopen - On
  • allow_url_include - Off

Recommended:

  • PHP 7.0.4 or higher (pH7CMS has been especially optimized for PHP 7+ and is about over 2x faster than older versions. Please note your server configuration can also change a lot your site performance).

Recommended Extensions:

  • APC module (for speed boost)
  • Gettext PHP extension (for better stability and optimization)
  • OpenSSL (for the "Connect" module)
  • iconv module

MySQL or MariaDB

Minimum:

  • Version - 5.0.15 or higher
  • InnoDB table support

Recommended:

  • MySQL/MariaDB 5.5 or higher